Juli 14, 2009

XP Netzwerkfreigaben Server 2008

Dieser Artikel löst ein seltsames Problem: Windows XP Rechner können keine Netzwerkfreigaben auf einem Server 2008 erreichen, Vista Clients können das aber.

Das Problem

Ein recht interessantes Phänomen: seit gestern können in einem Netzwerk die Windows XP-Clients die Netzwerkfreigaben auf einem Windows Server 2008 (Domänencontroller) nicht mehr aufrufen, die Vista-Clients sind aber in dazu in der Lage.

Die XP-Rechner sind in der Lage, den FQDN sauber aufzulösen, Ping funktioniert ebenfalls tadellos. Die Windows-Firewall ist ausgeschaltet und die Symantec-Endpoint Protection MR4 läuft (sowohl auf den XP- als auch auf den Vista-Maschinen). Zu Testzwecken habe ich diese auf einem der XP-Rechner ebenfalls deaktiviert.

Ich habe die Vorschläge von einem englischen Blog, der am 07.11.2004 gestartet wurde und der Kommentare bis 24.06.2009 enthält, der Reihe nach ausprobiert, doch führte das nicht zum Erfolg. Hier sind die Vorschläge des Posts:

Vorgeschlagene Maßnahmen

sfc /scannow

Konnte ich (noch) nicht durchführen, da mir die SP3 XP-CD fehlt

ping server

funktioniert

"Datei- und Druckerfreigabe für Microsoft-Netzwerke" in der Netzwerkkarte beim Client aktivieren

war aktiviert

„Datei- und Druckerfreigabe für Microsoft-Netzwerke“ in der Netzwerkkarte deinstallieren und wieder installieren

hat keinen Erfolg gebracht

In den „erweiterten Eigenschaften“ der Netzwerkkarte in der „Windows-Firewall“ die Ausnahme „Datei- und Druckerfreigabe“ aktivieren

war zwar nicht aktiviert, aber Windows-Firewall ist ausgeschaltet

Sicherstellen, dass der „Client für Microsoft-Netzwerke“ in der Netzwerkkarte beim Client vorhanden und aktiviert ist

vorhanden und aktiviert

In der Netzwerkkarte „Client für Microsoft-Netzwerke“ deinstallieren, Computer neu starten und wieder installieren

hat keinen Erfolg gebracht

Netzwerkkarte auf Dienst „Teefer2“ von Symantec überprüfen und wenn vorhanden, dann deaktivieren

nicht vorhanden

In der Netzwerkkarte in den „TCP/IP“-Eigenschaften auf dem Reiter „WINS“ überprüfen, dass der Punkt „NetBIOS über TCP/IP deaktivieren“ nicht markiert ist

war er nicht, es war der Standard-Punkt aktiviert

In der Netzwerkkarte in den „TCP/IP“-Eingenschaften auf dem Reiter „DNS“ folgende Dinge überprüfen/durchführen:
  • „DNS-Serveradressen in Verwendungsreihenfolge“ leeren
  • „Primäre und verbindungsspezifische DNS-Suffixe anhängen“ markieren
  • „Übergeordnete Suffixe des primären DNS-Suffixes anhängen“ markieren
  • „Diese DNS-Suffixe anhängen (in Reihenfolge)“ leeren
  • „DNS-Suffix für diese Verbindung“ leeren
  • „Adressen dieser Verbindung in DNS registrieren“ markieren
  • „DNS-Suffix dieser Verbindung in DNS-Registrierung verwenden“ demarkieren

Danach den Computer neu starten

war bereits alles so eingestellt, wie erforderlich

WLAN-Karte deaktivieren, um die Verbindung über Ethernet herzustellen

keine WLAN-Karte vorhanden

Microsoft Firewall ausschalten

war ausgeschaltet

Firewall-Ausnahmen für 4 Ports: TCP 139,445, und UDP 137,138

Firewall war ausgeschaltet

„Netzwerkbedrohungsschutz“ der Symantec Endpoint Protection ausschalten

Ausschalten brachte keinen Erfolg, außerdem funktioniert diese Einstellung auf den Vista-Rechnern (64 und 32 Bit)

„TCP/IP-NetBIOS-Hilfsprogramm“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„Arbeitsstationsdienst“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„Server“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„Computerbrowser“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„Remoteprozeduraufruf (RPC)“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„RPC-Locator“-Dienst starten und auf „Automatisch“ setzen

starten des Dienstes hat keinen Erfolg gebracht, also habe ich ihn auch auf „Manuell“ gelassen

„Arbeitsstationsdienst“ beenden und neu starten

Konnte nicht beendet werden, blieb in den Diensten mit dem Status „Wird beendet“ hängen; ich habe dann den Rechner neu gestartet.

„NT-LM-Sicherheitsdienst“-Dienst aktivieren und auf „Automatisch“ setzen

starten des Dienstes hat keinen Erfolg gebracht, also habe ich ihn auch auf „Manuell“ gelassen

„Webclient“-Dienst starten und auf „Automatisch“ setzen

war gestartet und stand schon auf „Automatisch“

„Systemeigenschaften“->“Erweitert“->“Systemleistung“->“Datenausführungsverhinderung“ den Punkt „Datenausführungsverhinderung nur für erforderliche Windows-Programme und -Dienste aktivieren“ aktivieren

war so eingestellt

Winsock XP Fix 1.2

hat keinen Erfolg gebracht

Aus der Domäne nehmen und nochmals einhängen

Alle XP-Rechner? Unwahrscheinlich.

In der lokalen Sicherheitsrichtlinie die „Netzwerksicherheit: LAN Manager-Authentifizierungsebene auf „LM- & NTLM-Antworten senden“ setzen

war gesetzt

Auf dem Domänencontroller den DNS-Eintrag des Clients entfernen und warten, bis er sich neu erstellt hat

hat keinen Erfolg gebracht

Den Computer in die host-Datei eintragen

noch nicht versucht

Quelle

Die Vorschläge dieses Posts kommen von hier. Den Post habe ich gefunden über folgenden Forumseintrag: https://forums.techguy.org/windows-server-2003-2008/842532-windows-xp-server-2008-network.html. Dieser ist vom 12.07.2009, also noch recht neu.

Hat noch jemand dieses Problem? Oder vielleicht sogar eine Lösung? Ich werde die noch nicht ausprobierten Lösungsvorschläge ausprobieren und die Ergebnisse posten. Vielleicht hat jemand ein ähnliches Problem und kann es mit einem der oben stehenden Vorschlägen lösen.

Hat dieses Problem schon jemand gehabt?

Update (15.07.2009)

Ich habe festgestellt, dass die XP-Maschine sich mit einem anderen Server 2008 verbinden kann, der nicht Teil der Domäne ist. Hier kann ich ganz normal auf die Shares zugreifen. Also muss die Blockade auf dem 2008er Server liegen.

Die Lösung

Weiteres Update (15.07.2009 21:11)

Problem gelöst! Da der Fehler beim Server 2008 liegen musste, habe ich diese Maschine neu gestartet. Als ich mich wieder angemeldet habe, kam eine Sprechblase hoch, dass Updates installiert und der Computer neu gestartet wurde. Scheinbar hatte er ein Update nicht richtig/fertig installiert und brauchte nochmals einen Neustart – den er mir übrigens nicht angezeigt hatte (in der Regel meckert der Computer ja, wenn er neu gestartet werden muss). Nach dem Neustart lief mit dem Zugriff von XP auf die Netzwerkfreigaben des Windows Server 2008 wieder alles glatt.



Über den Autor

Frank Piotrowsky ist IT-Consultant und beschäftigt sich mit der Automatisierung von Arbeitsprozessen, Netzwerkadministration und deren Automatisierung, sowie mit Software-Entwicklung, die ebenfalls in diese Richtung zielt. "Wenn der Computer die Arbeit für Sie erledigen kann, warum sollten Sie sie dann tun?" ist die Philosophie, die hinter dem Thema steckt.

Tags


Das könnte Sie auch interessieren:

Frank Piotrowsky

04/13/2020

Remotedesktopverbindung über Gateway


{"email":"Email address invalid","url":"Website address invalid","required":"Required field missing"}
>